linux 源码安装GO环境

7个月前 0 0 99

GO

Go安装1.4以上的版本出现的问题

个人在安装 go1.9.2的时候,一直 提醒的错误是:

Building Go bootstrap tool.

cmd/dist
ERROR: Cannot find /root/go1.4/bin/go.
Set $GOROOT_BOOTSTRAP to a working Go tree >= Go 1.4.

步骤

如果之前已经安装过老版本的Go,清除$GOPATH, $GOROOT变量。

安装好Git。

配置 Git

git config —global user.email “email-for-github”
git config —global user.name “user name”
创建SSH key,添加Public Key到Github账号。
ssh-keygen -t rsa -b 2048
复制~/.ssh/id_rsa.pub中的Public Key到github SSH settings以添加新的SSH key
安装 gcc和glibc-devel

sudo yum install gcc glibc-devel

从源代码编译安装Go1.4

cd ~/
git clone git@github.com:golang/go.git
cd go
git checkout -b 1.4.3 go1.4.3
cd src
./all.bash
复制 ~/go 到 $GOROOT_BOOTSTRAP(默认值是~/go1.4)
cp ~/go ~/go1.4 -rf

从源代码编译安装Go[version]

cd ~/go
git clean -dfx
git checkout -b version go[version]
cd src
./all.bash
设置 $GOPATH 以及添加Go二进制路径到 $PATH
sudo vi /etc/profile

# Golang Env
export GOROOT=/root/go
export GOBIN=$GOROOT/bin
export GOPATH=/xx/goProject

重启和测试

sudo source /etc/profile

go version

go version go linux/amd64

尽量找编译好的吧, 这编译时间其实还是挺长的

版权声明:自由转载-非商用-非衍生-保持署名(创意共享3.0许可证)

评论 (0)

    暂无评论~

njphper@copyright From 2014 to 2019-02-17